GPS Data Issue Berth Maps

Incident Report for Mistral Data

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 09:34 GMT

Investigating

Berth Maps is receiving incorrect GPS data from some GWR services. Service location by TD and TRUST are not affected. We have raised it with the GPS data supplier.
Posted Feb 18, 2026 - 09:33 GMT
This incident affected: Berth Maps.