MD Identity SSO Issues

Incident Report for Mistral Data

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 14:38 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 12:12 BST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 08:32 BST

Investigating

We have have identified an issue with our Single Sign-On Services (Identity), some customers may be unable to reach the portal and applications.
We apologise for any inconvenience and will post another update as soon as we learn more.
Posted Apr 13, 2026 - 08:31 BST
This incident affected: Berth Maps, MD Identity SSO, Sarma, Sirocco, Ventoux, Zonda and Staff Applications (Solano).